summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas Munro <tmunro@postgresql.org>2022-08-14 09:53:28 +1200
committerThomas Munro <tmunro@postgresql.org>2022-08-14 09:53:28 +1200
commit5579388d2dda60ded329a4623f9b4529e91a1b24 (patch)
tree01eacd42c65c6d419f5b2d6caf85e2cfefc5653b /configure.ac
parentde42bc3ac8f7205f2c302b402e40704ceb46a70c (diff)
downloadpostgresql-5579388d2dda60ded329a4623f9b4529e91a1b24.tar.gz
Remove replacement code for getaddrinfo.
SUSv3, all targeted Unixes and modern Windows have getaddrinfo() and related interfaces. Drop the replacement implementation, and adjust some headers slightly to make sure that the APIs are visible everywhere using standard POSIX headers and names. Reviewed-by: Tom Lane <tgl@sss.pgh.pa.us> Discussion: https://postgr.es/m/CA%2BhUKG%2BL_3brvh%3D8e0BW_VfX9h7MtwgN%3DnFHP5o7X2oZucY9dg%40mail.gmail.com
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 0 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index f8ab273674..e4156a78be 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1619,7 +1619,6 @@ PGAC_STRUCT_TIMEZONE
PGAC_UNION_SEMUN
AC_CHECK_TYPES(socklen_t, [], [], [#include <sys/socket.h>])
PGAC_STRUCT_SOCKADDR_STORAGE_MEMBERS
-PGAC_STRUCT_ADDRINFO
PGAC_TYPE_LOCALE_T
@@ -1849,16 +1848,6 @@ if test "$PORTNAME" = "win32" -o "$PORTNAME" = "cygwin"; then
AC_MSG_NOTICE([On $host_os we will use our strtof wrapper.])
fi
-# System's version of getaddrinfo(), if any, may be used only if we found
-# a definition for struct addrinfo; see notes in src/include/getaddrinfo.h.
-# We use only our own getaddrinfo.c on Windows, but it's time to revisit that.
-if test x"$ac_cv_type_struct_addrinfo" = xyes && \
- test "$PORTNAME" != "win32"; then
- AC_REPLACE_FUNCS([getaddrinfo])
-else
- AC_LIBOBJ(getaddrinfo)
-fi
-
# Similarly, use system's getopt_long() only if system provides struct option.
if test x"$ac_cv_type_struct_option" = xyes ; then
AC_REPLACE_FUNCS([getopt_long])