summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas Munro <tmunro@postgresql.org>2022-08-05 09:38:36 +1200
committerThomas Munro <tmunro@postgresql.org>2022-08-05 09:38:36 +1200
commit71f5dc6dfb3de50de28ddde53793540c2fa98b1f (patch)
treebda25fad6c14f222f5f0e6416fe92bb3b3fc03af /configure.ac
parentb79ec732d29fe42e91aeab4da62d446f226b594a (diff)
downloadpostgresql-71f5dc6dfb3de50de28ddde53793540c2fa98b1f.tar.gz
Remove dead setenv, unsetenv replacement code.
setenv() and unsetenv() are in SUSv3 and targeted Unix systems have them. We still need special code for these on Windows, but that doesn't require a configure probe. This marks the first time we require a SUSv3 (POSIX.1-2001) facility (rather than SUSv2). The replacement code removed here was not needed on any targeted system or any known non-EOL'd Unix system, and was therefore dead and untested. No need for vestigial HAVE_SETENV and HAVE_UNSETENV macros, because we provide a replacement for Windows, and we didn't previously test the macros. Reviewed-by: Tom Lane <tgl@sss.pgh.pa.us> Reviewed-by: Greg Stark <stark@mit.edu> Reviewed-by: Robert Haas <robertmhaas@gmail.com> Reviewed-by: Andres Freund <andres@anarazel.de> Discussion: https://postgr.es/m/CA+hUKGJ3LHeP9w5Fgzdr4G8AnEtJ=z=p6hGDEm4qYGEUX5B6fQ@mail.gmail.com
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 0 insertions, 13 deletions
diff --git a/configure.ac b/configure.ac
index 7f8a20d97b..d551cb2acd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1898,19 +1898,6 @@ if test "$PORTNAME" = "win32" -o "$PORTNAME" = "cygwin"; then
AC_MSG_NOTICE([On $host_os we will use our strtof wrapper.])
fi
-case $host_os in
- # Windows uses a specialised env handler
- mingw*)
- AC_DEFINE(HAVE_SETENV, 1, [Define to 1 because replacement version used.])
- AC_DEFINE(HAVE_UNSETENV, 1, [Define to 1 because replacement version used.])
- ac_cv_func_setenv=yes
- ac_cv_func_unsetenv=yes
- ;;
- *)
- AC_REPLACE_FUNCS([setenv unsetenv])
- ;;
-esac
-
# System's version of getaddrinfo(), if any, may be used only if we found
# a definition for struct addrinfo; see notes in src/include/getaddrinfo.h.
# We use only our own getaddrinfo.c on Windows, but it's time to revisit that.