summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas Munro <tmunro@postgresql.org>2022-08-05 11:43:14 +1200
committerThomas Munro <tmunro@postgresql.org>2022-08-05 14:04:02 +1200
commita0dc82711221aa220c5246fe788e5ed28924a4ea (patch)
tree09548e065aea773708922bf263e7cb51d261a6c2 /configure.ac
parent718fe0a14add0fadb17d715d7aa24ebcf3fb35c4 (diff)
downloadpostgresql-a0dc82711221aa220c5246fe788e5ed28924a4ea.tar.gz
Simplify replacement code for preadv and pwritev.
preadv() and pwritev() are not standardized by POSIX, but appeared in NetBSD in 1999 and were adopted by at least OpenBSD, FreeBSD, DragonFlyBSD, Linux, AIX, illumos and macOS. We don't use them much yet, but an active proposal uses them heavily. In 15, we had two replacement implementations for other OSes: one based on lseek() + -v function if available for true vector I/O, and the other based on a loop over p- function. The former would be an obstacle to hypothetical future multi-threaded code sharing file descriptors, while the latter would not, since commit cf112c12. Furthermore, the number of targeted systems that could benefit from the former's potential upside has dwindled to just one niche OS, since macOS added the functions and we de-supported HP-UX. That doesn't seem like a good trade-off. Therefore, drop the lseek()-based variant, and also the pg_ prefix now that the file position portability hazard is gone. At the time of writing, the only systems in our build farm that lack native preadv/pwritev and thus use fallback code are: * Solaris (but not illumos) * macOS before release 11.0 * Windows With this commit, the above systems will now use the *same* fallback code, the version that loops over pread()/pwrite(). Windows already used that (though a later proposal may include true vector I/O for Windows), so this decision really only affects Solaris, until it gets around to adding these system calls. Also remove some useless includes while here. Reviewed-by: Andres Freund <andres@anarazel.de> Discussion: https://postgr.es/m/CA+hUKGJ3LHeP9w5Fgzdr4G8AnEtJ=z=p6hGDEm4qYGEUX5B6fQ@mail.gmail.com
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 0 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index cd29d533a5..2938c9c7de 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1803,7 +1803,6 @@ AC_CHECK_FUNCS(m4_normalize([
posix_fallocate
ppoll
pthread_is_threaded_np
- readv
setproctitle
setproctitle_fast
strchrnul
@@ -1812,7 +1811,6 @@ AC_CHECK_FUNCS(m4_normalize([
sync_file_range
uselocale
wcstombs_l
- writev
]))
# These typically are compiler builtins, for which AC_CHECK_FUNCS fails.