summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas Munro <tmunro@postgresql.org>2022-08-26 10:13:22 +1200
committerThomas Munro <tmunro@postgresql.org>2022-08-26 10:18:30 +1200
commitbcc8b14ef630b2ad9aae7813981fb248fbff9ed8 (patch)
tree522dcfb926b2b235137aec71256dbb281c1dd5af /configure.ac
parent28ec316787674dd74d00b296724a009b6edc2fb0 (diff)
downloadpostgresql-bcc8b14ef630b2ad9aae7813981fb248fbff9ed8.tar.gz
Remove configure probe for sockaddr_in6 and require AF_INET6.
SUSv3 <netinet/in.h> defines struct sockaddr_in6, and all targeted Unix systems have it. Windows has it in <ws2ipdef.h>. Remove the configure probe, the macro and a small amount of dead code. Also remove a mention of IPv6-less builds from the documentation, since there aren't any. This is similar to commits f5580882 and 077bf2f2 for Unix sockets. Even though AF_INET6 is an "optional" component of SUSv3, there are no known modern operating system without it, and it seems even less likely to be omitted from future systems than AF_UNIX. Reviewed-by: Andres Freund <andres@anarazel.de> Discussion: https://postgr.es/m/CA+hUKGKErNfhmvb_H0UprEmp4LPzGN06yR2_0tYikjzB-2ECMw@mail.gmail.com
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 0 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 6ff294d405..993b5d5cb0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1801,12 +1801,6 @@ AC_CHECK_DECLS([pwritev], [], [AC_LIBOBJ(pwritev)], [#include <sys/uio.h>])
# This is probably only present on macOS, but may as well check always
AC_CHECK_DECLS(F_FULLFSYNC, [], [], [#include <fcntl.h>])
-AC_CHECK_TYPE([struct sockaddr_in6],
- [AC_DEFINE(HAVE_IPV6, 1, [Define to 1 if you have support for IPv6.])],
- [],
-[$ac_includes_default
-#include <netinet/in.h>])
-
AC_CACHE_CHECK([for PS_STRINGS], [pgac_cv_var_PS_STRINGS],
[AC_LINK_IFELSE([AC_LANG_PROGRAM(
[#include <machine/vmparam.h>