summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas Munro <tmunro@postgresql.org>2022-08-07 12:42:11 +1200
committerThomas Munro <tmunro@postgresql.org>2022-08-07 12:42:41 +1200
commitcbf4403134738245db48b306c62eb1258f2b2bd0 (patch)
tree8701627bd54d0a1fc23ac0180dc3608d019044f5 /configure.ac
parent24c3ce8f1c707f9eeb1f68cebd44c2516ff799c2 (diff)
downloadpostgresql-cbf4403134738245db48b306c62eb1258f2b2bd0.tar.gz
Simplify replacement code for strtof.
strtof() is in C99 and all targeted systems have it. We can remove the configure probe and some dead code, but we still need replacement code for a couple of systems that have known buggy implementations selected via platform template. Reviewed-by: Tom Lane <tgl@sss.pgh.pa.us> Discussion: https://postgr.es/m/152683.1659830125%40sss.pgh.pa.us
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 1 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index efd3be91cd..be52e17ea7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1874,7 +1874,6 @@ AC_REPLACE_FUNCS(m4_normalize([
strlcat
strlcpy
strnlen
- strtof
]))
if test "$enable_thread_safety" = yes; then
@@ -1885,8 +1884,7 @@ if test "$PORTNAME" = "win32" -o "$PORTNAME" = "cygwin"; then
# Cygwin and (apparently, based on test results) Mingw both
# have a broken strtof(), so substitute its implementation.
# That's not a perfect fix, since it doesn't avoid double-rounding,
- # but we have no better options. To get that, though, we have to
- # force the file to be compiled despite HAVE_STRTOF.
+ # but we have no better options.
AC_LIBOBJ([strtof])
AC_MSG_NOTICE([On $host_os we will use our strtof wrapper.])
fi