summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorPeter Eisentraut <peter_e@gmx.net>2002-02-23 04:17:47 +0000
committerPeter Eisentraut <peter_e@gmx.net>2002-02-23 04:17:47 +0000
commit42c3381fc7d90d196a19118e707705ce9a40f8af (patch)
tree5bfb3c40d900e319cba6128c864e1796783e685a /configure.in
parent0055a3939048c8b7190f1a993a9a364657fe90e7 (diff)
downloadpostgresql-42c3381fc7d90d196a19118e707705ce9a40f8af.tar.gz
Heimdal support (Kerberos V implementation from KTH)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in25
1 files changed, 21 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index e645353d14..4befa619ee 100644
--- a/configure.in
+++ b/configure.in
@@ -725,10 +725,12 @@ if test "$with_krb4" = yes ; then
fi
if test "$with_krb5" = yes ; then
- AC_CHECK_LIB(com_err, [com_err], [], [AC_MSG_ERROR([library 'com_err' is required for Kerberos 5])])
- AC_CHECK_LIB(crypto, [krb5_encrypt], [],
- [AC_CHECK_LIB(k5crypto, [krb5_encrypt], [], [AC_MSG_ERROR([library 'crypto' or 'k5crypto' is required for Kerberos 5])])])
- AC_CHECK_LIB(krb5, [krb5_sendauth], [], [AC_MSG_ERROR([library 'krb5' is required for Kerberos 5])])
+ AC_SEARCH_LIBS(com_err, [krb5 'krb5 -ldes -lasn1 -lroken' com_err], [],
+ [AC_MSG_ERROR([could not find function 'com_err' required for Kerberos 5])])
+ AC_SEARCH_LIBS(krb5_encrypt, [krb5 'krb5 -ldes -lasn1 -lroken' crypto k5crypto], [],
+ [AC_MSG_ERROR([could not find function 'krb5_encrypt' required for Kerberos 5])])
+ AC_SEARCH_LIBS(krb5_sendauth, [krb5 'krb5 -ldes -lasn1 -lroken'], [],
+ [AC_MSG_ERROR([could not find function 'krb5_sendauth' required for Kerberos 5])])
fi
if test "$with_openssl" = yes ; then
@@ -802,6 +804,21 @@ PGAC_STRUCT_FCRED
PGAC_STRUCT_SOCKCRED
PGAC_STRUCT_SOCKADDR_UN
+if test "$with_krb5" = yes; then
+# Check for differences between MIT and Heimdal (KTH) releases
+ PGAC_CHECK_MEMBER([krb5_ticket.enc_part2], [],
+ [PGAC_CHECK_MEMBER([krb5_ticket.client], [],
+ [AC_MSG_ERROR([could not determine how to get client name from Kerberos 5 ticket])],
+ [#include <krb5.h>])],
+ [#include <krb5.h>])
+ PGAC_CHECK_MEMBER([krb5_error.text.data], [],
+ [PGAC_CHECK_MEMBER([krb5_error.e_data], [],
+ [AC_MSG_ERROR([could not determine how to extract Kerberos 5 error messages])],
+ [#include <krb5.h>])],
+ [#include <krb5.h>])
+fi
+
+
##
## Functions, global variables
##