summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorBruce Momjian <bruce@momjian.us>2002-07-07 20:28:25 +0000
committerBruce Momjian <bruce@momjian.us>2002-07-07 20:28:25 +0000
commit4f4753832ece907ee68fd4136fc0137966c74608 (patch)
tree92883ac761ac9ac81d892a2e185acf0ecae569d0 /configure.in
parent712f69ece8c1221435371a4c0099b20ba81f15a2 (diff)
downloadpostgresql-4f4753832ece907ee68fd4136fc0137966c74608.tar.gz
Move CXX platform-specific stuff into template files.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 7 insertions, 7 deletions
diff --git a/configure.in b/configure.in
index 0accbce508..479c300cd8 100644
--- a/configure.in
+++ b/configure.in
@@ -1,5 +1,5 @@
dnl Process this file with autoconf to produce a configure script.
-dnl $Header: /cvsroot/pgsql/configure.in,v 1.186 2002/05/28 16:57:53 petere Exp $
+dnl $Header: /cvsroot/pgsql/configure.in,v 1.187 2002/07/07 20:28:24 momjian Exp $
dnl
dnl Developers, please strive to achieve this order:
dnl
@@ -243,6 +243,10 @@ AC_SUBST(enable_debug)
# variable.
PGAC_ARG_REQ(with, CC, [], [CC=$with_CC])
+# Set here so it can be over-ridden in the template file
+GCC_CXXFLAGS="-O2"
+VENDOR_CXXFLAGS=""
+
case $template in
aix) pgac_cc_list="gcc xlc";;
irix) pgac_cc_list="cc";; # no gcc
@@ -593,13 +597,9 @@ PGAC_ARG_OPTARG(with, CXX, [ --with-CXX build C++ modules (libpq++
AC_PROG_CXX
if test "$ac_env_CXXFLAGS" != set; then
if test "$GXX" = yes; then
- CXXFLAGS=-O2
+ CXXFLAGS="$GCC_CXXFLAGS"
else
- case $template in
- osf) CXXFLAGS='-O4 -Olimit 2000' ;;
- unixware) CXXFLAGS='-O' ;;
- *) CXXFLAGS= ;;
- esac
+ CXXFLAGS="$VENDOR_CXXFLAGS"
fi
fi
if test "$enable_debug" = yes && test "$ac_cv_prog_cxx_g" = yes; then