summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorBruce Momjian <bruce@momjian.us>2002-09-02 16:14:01 +0000
committerBruce Momjian <bruce@momjian.us>2002-09-02 16:14:01 +0000
commit75803a01634a778b0f0efe11364cbf453a981e6a (patch)
treefedbf5c217733452c04b048affbcf04d08e4b815 /configure.in
parent12e5b8dbcb90f2365ed3b18326e027b739e251eb (diff)
downloadpostgresql-75803a01634a778b0f0efe11364cbf453a981e6a.tar.gz
Add check for Ant version >= 1.5.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 6 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index cafc2d0542..e503c4b7b3 100644
--- a/configure.in
+++ b/configure.in
@@ -1,5 +1,5 @@
dnl Process this file with autoconf to produce a configure script.
-dnl $Header: /cvsroot/pgsql/configure.in,v 1.200 2002/08/30 17:14:30 momjian Exp $
+dnl $Header: /cvsroot/pgsql/configure.in,v 1.201 2002/09/02 16:14:01 momjian Exp $
dnl
dnl Developers, please strive to achieve this order:
dnl
@@ -381,6 +381,9 @@ PGAC_ARG_BOOL(with, java, no, [ --with-java build JDBC interface an
PGAC_PATH_ANT
if test -z "$ANT"; then
AC_MSG_ERROR([Ant is required to build Java components])
+fi
+if "$ANT" -version | sed q | egrep -v ' 1\.[[5-9]]| [[2-9]]\.' >/dev/null ; then
+ AC_MSG_ERROR([Ant version >= 1.5 is required to build Java components])
fi],
[AC_MSG_RESULT(no)])
AC_SUBST(with_java)
@@ -835,7 +838,7 @@ esac
HPUXMATHLIB=""
case $host_cpu in
hppa1.1)
- if [[ -r /lib/pa1.1/libm.a ]] ; then
+ if test -r /lib/pa1.1/libm.a ; then
HPUXMATHLIB="-L /lib/pa1.1 -lm"
fi ;;
esac
@@ -931,7 +934,7 @@ fi
dnl If we need to use "long long int", figure out whether nnnLL notation works.
-if [[ x"$HAVE_LONG_LONG_INT_64" = xyes ]] ; then
+if test x"$HAVE_LONG_LONG_INT_64" = xyes ; then
AC_TRY_COMPILE([
#define INT64CONST(x) x##LL
long long int foo = INT64CONST(0x1234567890123456);