summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorAndres Freund <andres@anarazel.de>2023-03-10 17:18:52 -0800
committerAndres Freund <andres@anarazel.de>2023-03-11 13:24:40 -0800
commit4e633016abe9b82053aafb2fe9d3317add73f74d (patch)
tree97fd5ef99fab3a47ec2bbcbcaf447ce555b1603f /meson.build
parent1925ac281a238fab50e208548f98daffdaaa0896 (diff)
downloadpostgresql-4e633016abe9b82053aafb2fe9d3317add73f74d.tar.gz
meson: fix header path of ossp-uuid
The ossp-uuid pkg-config file includes the necessary -I to include the header as uuid.h. Previously this would only work if ossp-uuid has its headers in ossp/ in an already searched path. Reported-by: Andrew Dunstan <andrew@dunslane.net> Discussion: https://postgr.es/m/7bb8b8a5-5297-ab3c-3412-466fd0124d00@dunslane.net
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 2409cc2254..d4384f1bf6 100644
--- a/meson.build
+++ b/meson.build
@@ -1268,7 +1268,7 @@ if uuidopt != 'none'
elif uuidopt == 'ossp'
uuid = dependency('ossp-uuid', required: true)
uuidfunc = 'uuid_export'
- uuidheader = 'ossp/uuid.h'
+ uuidheader = 'uuid.h'
else
error('huh')
endif