summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPeter Eisentraut <peter@eisentraut.org>2023-03-29 09:24:37 +0200
committerPeter Eisentraut <peter@eisentraut.org>2023-03-29 09:48:18 +0200
commit5aae36dc9c6842e4269b4a713f7ac6583bd8a318 (patch)
treee5994ea6606dc23a9ebd6184b13875c77eec2241 /meson.build
parent563f21cda8fcb61a0b5f071affb79c86458e52f8 (diff)
downloadpostgresql-5aae36dc9c6842e4269b4a713f7ac6583bd8a318.tar.gz
meson: Change default buildtype to debugoptimized
This matches the Autoconf default (-O2 + debug) better. The previous default setting "release" used -O3, which resulted in different compiler warnings. At least for now, we want to avoid such divergence. Discussion: https://www.postgresql.org/message-id/flat/CAFj8pRBJD_Y-XcqwXSbWS24z%2B84FFX7ajhCan9ixc_m4bD63sA%40mail.gmail.com
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 61e94be864..5e708d9045 100644
--- a/meson.build
+++ b/meson.build
@@ -18,7 +18,7 @@ project('postgresql',
default_options: [
'warning_level=1', #-Wall equivalent
'b_pch=false',
- 'buildtype=release',
+ 'buildtype=debugoptimized', # -O2 + debug
# For compatibility with the autoconf build, set a default prefix. This
# works even on windows, where it's a drive-relative path (i.e. when on
# d:/somepath it'll install to d:/usr/local/pgsql)