summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorAndres Freund <andres@anarazel.de>2022-09-28 09:48:09 -0700
committerAndres Freund <andres@anarazel.de>2022-09-28 18:48:19 -0700
commitcaeeabd11066a360c8a9986581da320dd5aa09b9 (patch)
tree805fb68472166b8dd464e4f4e642201c3b1efaf0 /meson.build
parentdfefa0e46433a2c798281826f8501895f3fa2a71 (diff)
downloadpostgresql-caeeabd11066a360c8a9986581da320dd5aa09b9.tar.gz
meson: mingw: Allow multiple definitions
I didn't carry this forward from the win32 template. It's not needed anymore for the reason stated therein, but it turns out to be required to e.g. override getopt. Possibly a better solution exists, but that's for later. Discussion: http://postgr.es/m/20220928022724.erzuk5v4ai4b53do@awork3.anarazel.de
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 02c086c04e..cd410319f3 100644
--- a/meson.build
+++ b/meson.build
@@ -277,6 +277,8 @@ elif host_system == 'windows'
# ldflags += '/nxcompat' # generated by msbuild, should have it for ninja?
else
ldflags += '-Wl,--stack,@0@'.format(cdata.get('WIN32_STACK_RLIMIT'))
+ # Need to allow multiple definitions, we e.g. want to override getopt.
+ ldflags += '-Wl,--allow-multiple-definition'
endif
os_deps += cc.find_library('ws2_32', required: true)