summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEivind Næss <eivnaes@yahoo.com>2022-07-30 14:33:15 -0700
committerEivind Næss <eivnaes@yahoo.com>2022-08-08 11:22:46 -0700
commit66a8c74c3f73d7480a09923a225b56b8829ae790 (patch)
tree7ed0b4e062afd45f9ccd981c68c40e32380a7aea /configure.ac
parent2a7caa2b79ff1edd5d19aa8c41d5614e526f1b93 (diff)
downloadppp-66a8c74c3f73d7480a09923a225b56b8829ae790.tar.gz
Let ./configure control the paths for pppd
This was previously done by specifying an overriding value for _ROOT_PATH. With this change, this variable is now gone. Instead, pathnames.h will use the SYSCONFDIR and LOCALSTATEDIR to resolve these paths. These directories is already controlled by configure. Package maintainers should be aware though that this may change their current configuration. The convential ./configure way is to specify: ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var/run --with-plugin-dir=/usr/lib/pppd/2.4.10 If one omit the --sysconfdir option, then the default location is by ${prefix}/etc which may not be what you want. Signed-off-by: Eivind Næss <eivnaes@yahoo.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 5 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 5a134fa..c94bfa0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -194,7 +194,7 @@ AS_IF([test "x$enable_openssl_engine" != "xno"], [],
#
# Specify runtime directory
AC_ARG_WITH([plugin-dir],
- AC_HELP_STRING([--with-plugin-dir=DIR], [Specify the plugin directory for pppd]))
+ AS_HELP_STRING([--with-plugin-dir=DIR],[Specify the plugin directory for pppd]))
AS_IF([test -n "$with_plugin_dir"],
[PPPD_PLUGIN_DIR="$with_plugin_dir"],
[PPPD_PLUGIN_DIR="${libdir}/pppd/$VERSION"])
@@ -203,19 +203,19 @@ AC_SUBST(PPPD_PLUGIN_DIR, "$PPPD_PLUGIN_DIR", [The pppd plugin directory])
#
# Specify runtime directory
AC_ARG_WITH([runtime-dir],
- AC_HELP_STRING([--with-runtime-dir=DIR], [Specify the runtime directory for pppd]))
+ AS_HELP_STRING([--with-runtime-dir=DIR],[Specify the runtime directory for pppd]))
AS_IF([test -n "$with_runtime_dir"],
[PPPD_RUNTIME_DIR="$with_runtime_dir"],
- [PPPD_RUNTIME_DIR="${localstatedir}/run/pppd"])
+ [PPPD_RUNTIME_DIR="${runstatedir}/pppd"])
AC_SUBST(PPPD_RUNTIME_DIR)
#
# Specify runtime directory
AC_ARG_WITH([logfile-dir],
- AC_HELP_STRING([--with-logfile-dir=DIR], [Specify the log directory for pppd]))
+ AS_HELP_STRING([--with-logfile-dir=DIR],[Specify the log directory for pppd]))
AS_IF([test -n "$with_logfile_dir"],
[PPPD_LOGFILE_DIR="$with_logfile_dir"],
- [PPPD_LOGFILE_DIR="${localstatedir}/log/pppd"])
+ [PPPD_LOGFILE_DIR="${localstatedir}/log/ppp"])
AC_SUBST(PPPD_LOGFILE_DIR)
#