summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEivind Næss <eivnaes@yahoo.com>2021-08-06 09:14:02 -0700
committerEivind Næss <eivnaes@yahoo.com>2022-07-15 15:25:38 -0700
commit80b8744eb42c7493794f3e3fe0bf1ce14f53e6dd (patch)
tree68a56cc56bb20629f2a7304f1a323022eb4ebb2b /configure.ac
parenta6622771e2dc03a2682c86c4bcf6bf6ae9e85df7 (diff)
downloadppp-80b8744eb42c7493794f3e3fe0bf1ce14f53e6dd.tar.gz
Changing INET6 to PPP_WITH_IPV6CP and adding configure option
Based on feedback on PR #296, the option ipv6-support seems inconsistent with the existing ipxcp option. Futhermore, the #define has been renamed to avoid bleeding into third party projects. pppdconf.h is already distributed and will define or undefine the PPP_WITH_IPV6CP define. Signed-off-by: Eivind Næss <eivnaes@yahoo.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 6 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index dd22dc6..85688a8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -143,11 +143,11 @@ AS_IF([test "x${enable_mslanman}" = "xyes" && test "x${enable_microsoft_extensio
#
# Disable IPv6 support
-AC_ARG_ENABLE([ipv6-support],
- AS_HELP_STRING([--disable-ipv6-support], [Disable IPv6 support]))
-AM_CONDITIONAL(WITH_INET6, test "x${enable_ipv6_support}" != "xno")
-AM_COND_IF([WITH_INET6],
- AC_DEFINE(INET6, 1, ["Have IPv6 support"]))
+AC_ARG_ENABLE([ipv6cp],
+ AS_HELP_STRING([--disable-ipv6cp], [Disable IPv6 Control Protocol]))
+AM_CONDITIONAL(PPP_WITH_IPV6CP, test "x${enable_ipv6cp}" != "xno")
+AM_COND_IF([PPP_WITH_IPV6CP],
+ AC_DEFINE(PPP_WITH_IPV6CP, 1, ["Have IPv6 Control Protocol"]))
#
# Disable Multilink support
@@ -410,6 +410,7 @@ Features enabled
Multilink............: ${enable_multilink:-no}
Plugins..............: ${enable_plugins:-yes}
CBCP.................: ${enable_cbcp:-no}
+ IPV6CP...............: ${enable_ipv6cp:-yes}
EAP-TLS..............: ${enable_eaptls:-yes}
PEAP.................: ${enable_peap:-yes}
"