summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEivind Naess <eivnaes@yahoo.com>2023-04-23 11:30:43 -0700
committerEivind Naess <eivnaes@yahoo.com>2023-04-23 11:32:34 -0700
commit9d6d326b2530cffb1414e4c401675117c42d43ce (patch)
treeceecf3190989bf3f016d6ba5c947b7c7720ca309 /configure.ac
parent760ce18f82670eb81cc186fb792919339a2e2fbe (diff)
downloadppp-9d6d326b2530cffb1414e4c401675117c42d43ce.tar.gz
Add configure check to see if we have struct sockaddr_ll
Fixes issue #411. Signed-off-by: Eivind Naess <eivnaes@yahoo.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 1180f64..38b24af 100644
--- a/configure.ac
+++ b/configure.ac
@@ -75,7 +75,8 @@ AM_COND_IF([LINUX], [
linux/if_ether.h \
linux/if_packet.h \
netinet/if_ether.h \
- netpacket/packet.h])])
+ netpacket/packet.h])
+ AC_CHECK_TYPES([struct sockaddr_ll], [], [], [#include <linux/if_packet.h>])])
AC_CHECK_SIZEOF(unsigned int)
AC_CHECK_SIZEOF(unsigned long)