summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-08-08 06:36:58 +0100
committerEivind Næss <eivnaes@yahoo.com>2022-07-15 15:25:39 -0700
commitbe5a98ed5bbb902af242dadc95462d1d9b424929 (patch)
treee0110f36ebb20087b83ccac391bc0f506ae45f17 /configure.ac
parentbc52ce2cbdc6f97db1f2ca51ec9817dad9debf9a (diff)
downloadppp-be5a98ed5bbb902af242dadc95462d1d9b424929.tar.gz
configure.ac: use consistent x${VAR} = x${VALUE} test
May as well do it the same way throughout. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 5 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 013c46c..9018645 100644
--- a/configure.ac
+++ b/configure.ac
@@ -38,8 +38,8 @@ case "${host_os}" in
;;
esac
-AM_CONDITIONAL([LINUX], [test "${build_linux}" = "yes" ])
-AM_CONDITIONAL([SUNOS], [test "${build_sunos}" = "yes" ])
+AM_CONDITIONAL([LINUX], [test "x${build_linux}" = "xyes" ])
+AM_CONDITIONAL([SUNOS], [test "x${build_sunos}" = "xyes" ])
AM_COND_IF([SUNOS],
CFLAGS="$CFLAGS -DSOL2 -DSRV4")
@@ -171,7 +171,7 @@ AC_ARG_ENABLE([plugins],
AS_HELP_STRING([--disable-plugins], [Disable support for loadable plugins]))
AS_IF([test "x$enable_plugins" != "xno"],
AC_DEFINE([PPP_WITH_PLUGINS], 1, [Have support for loadable plugins]))
-AM_CONDITIONAL(PPP_WITH_PLUGINS, test "${enable_plugins}" != "no")
+AM_CONDITIONAL(PPP_WITH_PLUGINS, test "x${enable_plugins}" != "xno")
#
# Disable EAP-TLS support
@@ -226,7 +226,7 @@ AC_SUBST(PPPD_LOGFILE_DIR)
#
# Check for OpenSSL
AX_CHECK_OPENSSL
-AM_CONDITIONAL(WITH_OPENSSL, test "${with_openssl}" != "no")
+AM_CONDITIONAL(WITH_OPENSSL, test "x${with_openssl}" != "xno")
#
# Check if OpenSSL has compiled in support for various ciphers
@@ -258,7 +258,7 @@ AM_COND_IF([OPENSSL_HAVE_DES],,
#
# If OpenSSL doesn't support DES, then use the one from libcrypt (glibc dropped support for this in 2.27).
-AS_IF([test "${ac_cv_openssl_des}" = "no" ], [
+AS_IF([test "x${ac_cv_openssl_des}" = "xno" ], [
AC_CHECK_LIB([crypt], [encrypt],
[LIBS="$LIBS -lcrypt"],
[AC_MSG_ERROR([OpenSSL not found or does not support DES, and libcrypt also doesn't support encrypt])]