summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEivind Næss <eivnaes@yahoo.com>2021-08-10 06:50:18 -0700
committerEivind Næss <eivnaes@yahoo.com>2022-07-15 15:25:39 -0700
commitbfebf96caf375ab52e4df396f3383851d5ed2647 (patch)
treeb166e7942045f05080c6baa3755ef551a7c6d2dc /configure.ac
parent0f8817a4f973e16d9e174e7dd2310155b881a0ed (diff)
downloadppp-bfebf96caf375ab52e4df396f3383851d5ed2647.tar.gz
Update configure.ac to use AS_IF() and correct use of paranthesis
Signed-off-by: Eivind Næss <eivnaes@yahoo.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 2 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 24b3e12..ae69aa7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -105,10 +105,8 @@ AC_ARG_ENABLE([systemd],
AM_CONDITIONAL(WITH_SYSTEMD, test "x${enable_systemd}" = "xyes")
AM_COND_IF([WITH_SYSTEMD],
AC_DEFINE([SYSTEMD], 1, [Enable support for systemd notifications]))
-
-if test "x${enable_systemd}" = "xyes"; then
- PKG_CHECK_MODULES([systemd], [systemd])
-fi
+AS_IF([test "x${enable_systemd}" = "xyes"], [
+ PKG_CHECK_MODULES([systemd], [systemd])])
#
# Enable Callback Protocol Support, disabled by default