summaryrefslogtreecommitdiff
path: root/pppd/Makefile.am
diff options
context:
space:
mode:
authorEivind Næss <eivnaes@yahoo.com>2021-08-06 10:06:17 -0700
committerEivind Næss <eivnaes@yahoo.com>2022-07-15 15:25:39 -0700
commite8676075aea6d278f435d5ce83d9b6aa216a1ecb (patch)
tree06bd9f59ff45826629f39f0feaf7b3c836652c8d /pppd/Makefile.am
parent80b8744eb42c7493794f3e3fe0bf1ce14f53e6dd (diff)
downloadppp-e8676075aea6d278f435d5ce83d9b6aa216a1ecb.tar.gz
Changing defines for CHAPMS, MSLANMAN, MPPE to prefix with PPP_WITH_*
To avoid bleeding over to third party projects. They are all defined and exported by pppdconf.h either way. These projects will stil have a consistent view of how pppd was compiled. Signed-off-by: Eivind Næss <eivnaes@yahoo.com>
Diffstat (limited to 'pppd/Makefile.am')
-rw-r--r--pppd/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/pppd/Makefile.am b/pppd/Makefile.am
index bc9a6d9..94197fd 100644
--- a/pppd/Makefile.am
+++ b/pppd/Makefile.am
@@ -83,7 +83,7 @@ pppd_SOURCES += sys-solaris.c
pppd_LIBS += -lsocket -lnsl
endif
-if WITH_CHAPMS
+if PPP_WITH_CHAPMS
pppd_SOURCES += chap_ms.c
pppd_SOURCES += pppcrypt.c
check_PROGRAMS += utest_chap
@@ -97,7 +97,7 @@ if WITH_CBCP
pppd_SOURCES += cbcp.c
endif
-if WITH_MPPE
+if PPP_WITH_MPPE
pppd_SOURCES += mppe.c
endif