summaryrefslogtreecommitdiff
path: root/pppd/Makefile.am
diff options
context:
space:
mode:
authorEivind Næss <eivnaes@yahoo.com>2021-08-07 14:52:39 -0700
committerEivind Næss <eivnaes@yahoo.com>2022-07-15 15:25:39 -0700
commitf36f5f83a39058e3cd16d450f20d20fa32419076 (patch)
treeca51781922ea43cc92e0f6a47bb17beb9d5ce243 /pppd/Makefile.am
parent3d40f39afda944dc862001800c0b3696d2f9f181 (diff)
downloadppp-f36f5f83a39058e3cd16d450f20d20fa32419076.tar.gz
Changing USE_PAM to PPP_WITH_PAM for consistency.
Signed-off-by: Eivind Næss <eivnaes@yahoo.com>
Diffstat (limited to 'pppd/Makefile.am')
-rw-r--r--pppd/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/pppd/Makefile.am b/pppd/Makefile.am
index a7d64cf..c3f512f 100644
--- a/pppd/Makefile.am
+++ b/pppd/Makefile.am
@@ -127,8 +127,10 @@ if PPP_WITH_IPV6CP
pppd_SOURCES += ipv6cp.c eui64.c
endif
-if WITH_PAM
-pppd_LIBS += -lpam -ldl
+if PPP_WITH_PAM
+pppd_CPPFLAGS += $(PAM_CFLAGS)
+pppd_LIBS += $(PAM_LIBS) -ldl
+pppd_LDFLAGS += $(PAM_LDFLAGS)
endif
if PPP_WITH_EAPTLS