summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJim Warner <james.warner@comcast.net>2017-05-12 00:03:00 -0500
committerCraig Small <csmall@enc.com.au>2017-05-22 21:38:10 +1000
commit3d39e4fd889a9436dc37fa5a7dfa5922ba7829bc (patch)
treeb2cd4088d4cd25fd4ff0a2a4fb6ee0732d87e23c /Makefile.am
parent618a813baaefc9d744575955abbf5df506db9636 (diff)
downloadprocps-ng-3d39e4fd889a9436dc37fa5a7dfa5922ba7829bc.tar.gz
library: set stage for NUMA node field display support
In response to that suggestion referenced below, these changes allow display of task/thread level NUMA nodes. Currently, only the 'top' program offers any NUMA type support and it is limited to the Summary Area display. With this commit both the 'top' and 'ps' programs will be able to display NUMA nodes associated with threads. Reference(s): https://gitlab.com/procps-ng/procps/issues/58 Signed-off-by: Jim Warner <james.warner@comcast.net>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 2c4b8d6..d1dcf28 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -192,6 +192,8 @@ proc_libprocps_la_SOURCES = \
proc/meminfo.h \
proc/namespace.c \
proc/namespace.h \
+ proc/numa.c \
+ proc/numa.h \
proc/pids.c \
proc/pids.h \
proc/procps.h \
@@ -221,6 +223,7 @@ proc_libprocps_la_include_HEADERS = \
proc/devname.h \
proc/diskstats.h \
proc/escape.h \
+ proc/numa.h \
proc/pids.h \
proc/procps.h \
proc/pwcache.h \