summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorIssam E. Maghni <issam.e.maghni@mailbox.org>2021-04-23 15:58:36 -0400
committerCraig Small <csmall@dropbear.xyz>2021-04-24 11:29:48 +1000
commit71764980c382abd90daa5592b476b2645e24a98a (patch)
treef598ea49756630e7e7319301a1e5cc71aa5e7d39 /Makefile.am
parentc0827797692497ab1d3fc10696b850c81de0dd0c (diff)
downloadprocps-ng-71764980c382abd90daa5592b476b2645e24a98a.tar.gz
configure: Add --disable-w
Some systems implement utmp as a stub so it doesn't make sense to have a non-functioning w. This change mitigates #193 and !126 References: procps-ng/procps!129 procps-ng/procps!126 procps-ng/procps#193
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am21
1 files changed, 15 insertions, 6 deletions
diff --git a/Makefile.am b/Makefile.am
index ec3885b..2c40973 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -51,8 +51,7 @@ bin_PROGRAMS = \
pwdx \
tload \
uptime \
- vmstat \
- w
+ vmstat
if BUILD_PIDWAIT
bin_PROGRAMS += pidwait
endif
@@ -64,8 +63,7 @@ usrbin_exec_PROGRAMS += \
pkill \
pmap \
uptime \
- vmstat \
- w
+ vmstat
endif
lib_LTLIBRARIES = \
@@ -78,7 +76,6 @@ dist_man_MANS = \
pmap.1 \
uptime.1 \
vmstat.8 \
- w.1 \
doc/procps.3 \
doc/procps_pids.3 \
doc/procps_misc.3
@@ -144,6 +141,19 @@ else
EXTRA_DIST += kill.1
endif
+if BUILD_W
+if CYGWIN
+usrbin_exec_PROGRAMS += w
+else
+bin_PROGRAMS += w
+endif
+
+dist_man_MANS += w.1
+w_SOURCES = w.c lib/fileutils.c
+else
+ EXTRA_DIST += w.1
+endif
+
if WITH_NCURSES
if !CYGWIN
bin_PROGRAMS += \
@@ -222,7 +232,6 @@ endif
tload_SOURCES = tload.c lib/strutils.c lib/fileutils.c
uptime_SOURCES = uptime.c lib/fileutils.c
vmstat_SOURCES = vmstat.c lib/strutils.c lib/fileutils.c
-w_SOURCES = w.c lib/fileutils.c
# See http://www.gnu.org/software/libtool/manual/html_node/Updating-version-info.html