summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorCraig Small <csmall@dropbear.xyz>2022-04-26 22:04:05 +1000
committerCraig Small <csmall@dropbear.xyz>2022-04-26 22:04:05 +1000
commit9c5397a941bb80e9adb66b2be410247349df1d57 (patch)
tree871fc8f770c26d28131a2145054440a92069d0ed /Makefile.am
parent1f085f5a9f036625696bfa370779232f8f0b769c (diff)
downloadprocps-ng-9c5397a941bb80e9adb66b2be410247349df1d57.tar.gz
testsuite: Add check for shared memory
Created a test process test_shm that allocates a shared memory segment and prints the segment ID. pmap testsuite runs pmap to check that the segment is found. The value returned by shmget() is the same value that is printed in the fifth column /proc/<PID>/maps Signed-off-by: Craig Small <csmall@dropbear.xyz>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 4059e13..862a990 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -326,7 +326,8 @@ check_PROGRAMS = \
lib/test_strutils \
lib/test_fileutils \
lib/test_process \
- lib/test_strtod_nol
+ lib/test_strtod_nol \
+ lib/test_shm
lib_test_strutils_SOURCES = lib/test_strutils.c lib/strutils.c
lib_test_strutils_LDADD = $(CYGWINFLAGS)
@@ -336,6 +337,8 @@ lib_test_process_SOURCES = lib/test_process.c
lib_test_process_LDADD = $(CYGWINFLAGS)
lib_test_strtod_nol_SOURCES = lib/test_strtod_nol.c lib/strutils.c
lib_test_strtod_nol_LDADD = $(CYGWINFLAGS)
+lib_test_shm_SOURCES = lib/test_shm.c lib/strutils.c
+lib_test_shm_LDADD = $(CYGWINFLAGS)
check_PROGRAMS += \
proc/test_Itemtables \