summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJim Warner <james.warner@comcast.net>2020-07-01 00:00:00 -0500
committerCraig Small <csmall@dropbear.xyz>2020-07-05 21:13:01 +1000
commitd974f064b5a269fe8bd009d1430d17218aaf07b7 (patch)
tree4d6e757e3b961698b63c84166198ffb537db9619 /Makefile.am
parent605ea4a8f7460920b6de9e432757bd13f80f0dba (diff)
downloadprocps-ng-d974f064b5a269fe8bd009d1430d17218aaf07b7.tar.gz
build-sys: correct those installed development headers
These headers were used only in the library itself and it's wrong to have them in the user include directory. * devname.h .. is used only by: ... pids.c, readproc.c * numa.h ..... is used only by: ....... pids.c, stat.c * pwcache.h .. is used only by: ........... readproc.c * readproc.h . is used only by: ..... escape.c, pids.c * wchan.h .... is used only by: ............... pids.c Signed-off-by: Jim Warner <james.warner@comcast.net>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 0 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index e49dc10..52a97c4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -274,21 +274,16 @@ proc_libprocps_la_SOURCES = \
proc_libprocps_la_includedir = $(includedir)/procps/
proc_libprocps_la_include_HEADERS = \
- proc/devname.h \
proc/diskstats.h \
proc/meminfo.h \
proc/namespace.h \
- proc/numa.h \
proc/pids.h \
- proc/pwcache.h \
- proc/readproc.h \
proc/slabinfo.h \
proc/stat.h \
proc/sysinfo.h \
proc/uptime.h \
proc/version.h \
proc/vmstat.h \
- proc/wchan.h \
proc/xtra-procps-debug.h
pkgconfigdir = $(libdir)/pkgconfig