summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorFabrice Fontaine <fontaine.fabrice@gmail.com>2022-11-03 18:24:53 +0100
committerCraig Small <csmall@dropbear.xyz>2022-11-09 10:15:05 +0000
commit17f94796a9b3c4f1ff28829107a82107dcb362b4 (patch)
tree9860c6c03f4bba8c907bc3c5124d3b70f393d820 /configure.ac
parentd99c213af9c4a28c9232fe186fd0b10ea9b063f7 (diff)
downloadprocps-ng-17f94796a9b3c4f1ff28829107a82107dcb362b4.tar.gz
fix pifd_open check
Replace AC_CHECK_FUNC by AC_CHECK_FUNCS otherwise HAVE_PIDFD_OPEN will never be defined resulting in the following build failure if pidfd_open is available but __NR_pidfd_open is not available: pgrep.c: In function 'pidfd_open': pgrep.c:748:17: error: '__NR_pidfd_open' undeclared (first use in this function); did you mean 'pidfd_open'? 748 | return syscall(__NR_pidfd_open, pid, flags); | ^~~~~~~~~~~~~~~ | pidfd_open This build failure is raised since the addition of pwait in version 3.3.17 and https://gitlab.com/procps-ng/procps/-/commit/c8384e682c1cfb3b2dc797e0f8a3cbaaccf7a3da Fixes: - http://autobuild.buildroot.org/results/f23a5156e641b2ebdd673973dec0f9c87760c688 Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 629881a..1a3ccdb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -160,7 +160,7 @@ AC_TRY_COMPILE([#include <errno.h>],
AC_MSG_RESULT(yes),
AC_MSG_RESULT(no))
-AC_CHECK_FUNC([pidfd_open], [enable_pidwait=yes], [
+AC_CHECK_FUNCS([pidfd_open], [enable_pidwait=yes], [
AC_MSG_CHECKING([for __NR_pidfd_open])
AC_COMPILE_IFELSE([AC_LANG_SOURCE([
#include <sys/syscall.h>