summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJim Warner <james.warner@comcast.net>2013-04-08 00:00:00 -0500
committerCraig Small <csmall@enc.com.au>2013-04-14 22:28:42 +1000
commit53fd7dd1ed120f901cbb31e69453720b038a7ac6 (patch)
tree9a68e6790752226a9c97768278d0f0a5fb542425 /configure.ac
parent8d989c68c068541a814bf0d2340ac9b0373f24b5 (diff)
downloadprocps-ng-53fd7dd1ed120f901cbb31e69453720b038a7ac6.tar.gz
build-sys: in top program, enable NUMA/Node extensions
This patch provides the build system support for those top extensions dealing with the NUMA summary displays. For providing the initial impetus for this enhancement I wish to thank Lance Shelton <LShelton@fusionio.com>. (everything is perfectly justified plus right margins) (are completely filled, but of course it must be luck) Signed-off-by: Jim Warner <james.warner@comcast.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 9 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 6adf257..0a74197 100644
--- a/configure.ac
+++ b/configure.ac
@@ -229,15 +229,17 @@ AC_SEARCH_LIBS([numa_node_of_cpu], [numa],
AC_SUBST([NUMA_LIB])
AC_CHECK_HEADERS([numa.h])
AC_ARG_ENABLE([numa],
- AS_HELP_STRING([--disable-numa], [if otherwise available, disable NUMA support in top]),
- [], [disable_numa=no]
+ AS_HELP_STRING([--enable-numa], [enable NUMA/Node support in top]),
+ [enable_numa=yes], []
)
-if test "x$disable_numa" = x"no"; then
- if test x"$ac_cv_header_numa_h" = x"yes"; then
- if test x"$ac_cv_search_numa_node_of_cpu" != x"no"; then
- AC_DEFINE([NUMA_ENABLED], [1], [enable NUMA/Node support in top])
- fi
+if test "x$enable_numa" = x"yes"; then
+ if test x"$ac_cv_header_numa_h" = x"no"; then
+ AC_MSG_ERROR([top numa support requires header 'numa.h'])
+ fi
+ if test x"$ac_cv_search_numa_node_of_cpu" = x"no"; then
+ AC_MSG_ERROR([top numa support requires library 'libnuma'])
fi
+ AC_DEFINE([NUMA_ENABLED], [1], [enable NUMA/Node support in top])
fi
AC_ARG_ENABLE([w-from],