summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-03-07 15:36:59 -0500
committerCraig Small <csmall@enc.com.au>2016-03-10 22:30:02 +1100
commit69d019967295c5b15c6530a74bd61e13a23acc2f (patch)
tree1b54389bc9ad3502a47076eb5668582e747377cf /configure.ac
parent03437d7dd30363518792b690cd5d747e22f74f6b (diff)
downloadprocps-ng-69d019967295c5b15c6530a74bd61e13a23acc2f.tar.gz
enable transparent large file support
Historically LFS mattered only to open/read large files. A few programs here use open/seek, but not generally on files that are large. However, LFS also applies to stat which procps does in a bunch of places -- some filesystems have 64bit inodes and attempts to do a 32bit stat will throw an error. Enable transparent LFS everywhere to avoid this.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index d47ef5a..3711d3b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -12,7 +12,8 @@ AC_CONFIG_SRCDIR([free.c])
AC_CONFIG_HEADERS([config.h])
# Checks for programs.
-AC_USE_SYSTEM_EXTENSIONS(_GNU_SOURCE)
+AC_USE_SYSTEM_EXTENSIONS
+AC_SYS_LARGEFILE
AC_PROG_AWK
AC_PROG_CC
AC_PROG_CC_STDC