summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJaromir Capik <jcapik@redhat.com>2013-10-04 20:35:01 +0200
committerJaromir Capik <jcapik@redhat.com>2013-10-10 17:01:48 +0200
commitafe862ebe4be1b02cc5378c68965b7ee2cb9e3d7 (patch)
treebc1e9e015d71d202b916592d9975337869ab844c /configure.ac
parent099bf9a26a074a7f58442aa0c907980459afdc02 (diff)
downloadprocps-ng-afe862ebe4be1b02cc5378c68965b7ee2cb9e3d7.tar.gz
pidof: reimplemented from scratch (replacing sysvinit pidof)
As the sysvinit becomes obsolete, some of the bundled tools need to find a new home. The procps-ng project seems to be the most suitable project for adopting the pidof tool. This commit introduces a redesigned version of pidof that satisfies the LSB requirements. In corner cases the behaviour might differ from the former one as the new version doesn't use any stat(2) calls.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5487bd4..20bc3ce 100644
--- a/configure.ac
+++ b/configure.ac
@@ -168,6 +168,12 @@ else
fi
# AC_ARG_ENABLEs
+AC_ARG_ENABLE([pidof],
+ AS_HELP_STRING([--disable-pidof], [do not build pidof]),
+ [], [enable_pidof=yes]
+)
+AM_CONDITIONAL(BUILD_PIDOF, test "x$enable_pidof" = xyes)
+
AC_ARG_ENABLE([kill],
AS_HELP_STRING([--disable-kill], [do not build kill]),
[], [enable_kill=yes]