summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCraig Small <csmall@enc.com.au>2017-08-19 23:05:22 +1000
committerCraig Small <csmall@enc.com.au>2017-08-19 23:05:22 +1000
commitd8fb86dbc596ca1c70766b65c5fd6d29a6972da7 (patch)
tree7ffebbd95d5b131f3daf5e9c717e8177d071ab92 /configure.ac
parentaab30a0aad0849852c24ba28f5a31080c719a514 (diff)
downloadprocps-ng-d8fb86dbc596ca1c70766b65c5fd6d29a6972da7.tar.gz
Port of merge request 49 to newlib
Wayne Porter made !49 which added Cygwin support to the master branch This is the port of those changes to newlib
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 21 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 72ab273..4898a37 100644
--- a/configure.ac
+++ b/configure.ac
@@ -70,6 +70,27 @@ AC_FUNC_REALLOC
AC_FUNC_STRCOLL
AC_FUNC_STRTOD
+usrbin_execdir='${exec_prefix}/bin'
+AC_SUBST([usrbin_execdir])
+
+if test "x$host_os" = xcygwin
+then
+ prefix=/usr
+ sysconfdir='${prefix}/etc'
+ libexecdir='${prefix}/lib'
+ localstatedir='${prefix}/var'
+ datadir='${prefix}/share'
+ mandir='${prefix}/share/man'
+ infodir='${prefix}/share/info'
+ AC_SUBST([prefix])
+ AC_SUBST([sysconfdir])
+ AC_SUBST([libexecdir])
+ AC_SUBST([localstatedir])
+ AC_SUBST([datadir])
+ AC_SUBST([mandir])
+ AC_SUBST([infodir])
+fi
+
AM_GNU_GETTEXT_VERSION([0.14.1])
AM_GNU_GETTEXT([external])
if test -d "$srcdir/po"