summaryrefslogtreecommitdiff
path: root/src/pulse/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/pulse/meson.build')
-rw-r--r--src/pulse/meson.build12
1 files changed, 8 insertions, 4 deletions
diff --git a/src/pulse/meson.build b/src/pulse/meson.build
index 1b82c807c..40d407963 100644
--- a/src/pulse/meson.build
+++ b/src/pulse/meson.build
@@ -70,11 +70,15 @@ if glib_dep.found()
libpulse_headers += 'glib-mainloop.h'
endif
-run_target('update-map-file',
- command : [ join_paths(meson.source_root(), 'scripts/generate-map-file.sh'), 'map-file',
- [ libpulse_headers, 'simple.h', join_paths(meson.build_root(), 'src', 'pulse', 'version.h') ] ])
+if host_machine.system() != 'windows' and host_machine.system() != 'darwin'
+ run_target('update-map-file',
+ command : [ join_paths(meson.source_root(), 'scripts/generate-map-file.sh'), 'map-file',
+ [ libpulse_headers, 'simple.h', join_paths(meson.build_root(), 'src', 'pulse', 'version.h') ] ])
-versioning_link_args = '-Wl,-version-script=' + join_paths(meson.source_root(), 'src', 'pulse', 'map-file')
+ versioning_link_args = ['-Wl,-version-script=' + join_paths(meson.source_root(), 'src', 'pulse', 'map-file')]
+else
+ versioning_link_args = []
+endif
libpulse = shared_library('pulse',
libpulse_sources,