summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorRussell McConnachie <pmcconna@cisco.com>2020-05-14 15:27:30 -0700
committerRussell McConnachie <pmcconna@cisco.com>2020-05-14 15:27:30 -0700
commit591c18503645b555b555081fefd045b801e74140 (patch)
treeeea806649417d436b085fe459281bd6978493a77 /setup.py
parentccca1153de8ec145b00f3bb9a6e6a13b0f02db58 (diff)
downloadpycurl-591c18503645b555b555081fefd045b801e74140.tar.gz
Add convert_docstring() call to setup.py to ensure that src/docstrings.c, and src/docstrings.h are added so that Python installations with pip/setuptools are successful.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 2 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index b82d654..ee6b3f2 100644
--- a/setup.py
+++ b/setup.py
@@ -954,6 +954,8 @@ if __name__ == "__main__":
elif len(sys.argv) > 1 and sys.argv[1] == 'docstrings-sources':
gen_docstrings_sources()
else:
+ convert_docstrings()
+
setup_args['data_files'] = get_data_files()
if 'PYCURL_RELEASE' in os.environ and os.environ['PYCURL_RELEASE'].lower() in ['1', 'yes', 'true']:
split_extension_source = False