summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorwillmcgugan <willmcgugan@67cdc799-7952-0410-af00-57a81ceafa0f>2010-12-22 21:41:17 +0000
committerwillmcgugan <willmcgugan@67cdc799-7952-0410-af00-57a81ceafa0f>2010-12-22 21:41:17 +0000
commit1d8a0006495b683ed5e2ffb4daae4a80560a0c58 (patch)
treeaaa11ba21a252026ec8588c6101fc99e9aa7b2ce /setup.py
parentbe42d2e91646d7d4369ce9386c5c5a03a1e3141a (diff)
downloadpyfilesystem-git-1d8a0006495b683ed5e2ffb4daae4a80560a0c58.tar.gz
setup.py tweaks
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py23
1 files changed, 19 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index 08c4cef..2c4ea90 100644
--- a/setup.py
+++ b/setup.py
@@ -25,19 +25,34 @@ classifiers = [
'Topic :: System :: Filesystems',
]
+long_desc = """Pyfilesystem is a module that provides a simplified common interface to many types of filesystem. Filesystems exposed via Pyfilesystem can also be served over the network, or 'mounted' on the native filesystem.
+
+Even if you only need to work with file and directories on the local hard-drive, Pyfilesystem can simplify your code and make it more robust -- with the added advantage that you can change where the files are located by changing a single line of code.
+"""
+
setup(name='fs',
version=VERSION,
description="Filesystem abstraction",
- long_description="Creates a common interface to filesystems",
+ long_description=long_desc,
license = "BSD",
author="Will McGugan",
author_email="will@willmcgugan.com",
url="http://code.google.com/p/pyfilesystem/",
download_url="http://code.google.com/p/pyfilesystem/downloads/list",
platforms = ['any'],
- packages=['fs','fs.expose','fs.expose.fuse','fs.tests','fs.wrapfs',
- 'fs.osfs','fs.contrib','fs.contrib.bigfs','fs.contrib.davfs',
- 'fs.expose.dokan', 'fs.commands'],
+ packages=['fs',
+ 'fs.expose',
+ 'fs.expose.dokan',
+ 'fs.expose.fuse',
+ 'fs.expose.wsgi',
+ 'fs.tests',
+ 'fs.wrapfs',
+ 'fs.osfs',
+ 'fs.contrib',
+ 'fs.contrib.bigfs',
+ 'fs.contrib.davfs',
+ 'fs.contrib.tahoefs',
+ 'fs.commands'],
scripts=['fs/commands/%s.py' % command for command in COMMANDS],
classifiers=classifiers,
)