summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorwillmcgugan <willmcgugan@67cdc799-7952-0410-af00-57a81ceafa0f>2008-09-19 13:51:18 +0000
committerwillmcgugan <willmcgugan@67cdc799-7952-0410-af00-57a81ceafa0f>2008-09-19 13:51:18 +0000
commit200b12e36e29b3a50cc1de1058c988ef7e60895c (patch)
treedc335cd2ec1f11cdfd2037b9d2df152dd00cefe5 /setup.py
parent2bb681bafd1b7fc89fd125d5852a20ee861869fc (diff)
downloadpyfilesystem-200b12e36e29b3a50cc1de1058c988ef7e60895c.tar.gz
Tweaking setup.py
git-svn-id: http://pyfilesystem.googlecode.com/svn/trunk@90 67cdc799-7952-0410-af00-57a81ceafa0f
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py19
1 files changed, 18 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 8b95407..4a98348 100644
--- a/setup.py
+++ b/setup.py
@@ -1,7 +1,24 @@
+#!/user/bin/env python
+
from distutils.core import setup
+
from fs import __version__ as VERSION
+classifiers = [
+ 'Development Status :: 3 - Alpha',
+ 'Intended Audience :: Developers',
+ 'License :: OSI Approved :: Python Software Foundation License',
+ 'Operating System :: OS Independent',
+ 'Programming Language :: Python',
+ 'Topic :: System :: Filesystems',
+]
+
setup(name='fs',
version=VERSION,
- py_modules=['fs'],
+ description="A filesytem abstraction",
+ author="Will McGugan",
+ author_email="will@willmcgugan.com",
+ url="http://code.google.com/p/pyfilesystem/",
+ packages=['fs'],
+ classifiers=classifiers,
)