summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorwillmcgugan <willmcgugan@67cdc799-7952-0410-af00-57a81ceafa0f>2010-12-22 21:41:17 +0000
committerwillmcgugan <willmcgugan@67cdc799-7952-0410-af00-57a81ceafa0f>2010-12-22 21:41:17 +0000
commit79e1acd85ac89cd803d9855ae7aee165f0418d57 (patch)
treeaaa11ba21a252026ec8588c6101fc99e9aa7b2ce /setup.py
parent44e691c10e87430018e5a3febd02f787ade231f0 (diff)
downloadpyfilesystem-79e1acd85ac89cd803d9855ae7aee165f0418d57.tar.gz
setup.py tweaks
git-svn-id: http://pyfilesystem.googlecode.com/svn/trunk@569 67cdc799-7952-0410-af00-57a81ceafa0f
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py23
1 files changed, 19 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index 08c4cef..2c4ea90 100644
--- a/setup.py
+++ b/setup.py
@@ -25,19 +25,34 @@ classifiers = [
'Topic :: System :: Filesystems',
]
+long_desc = """Pyfilesystem is a module that provides a simplified common interface to many types of filesystem. Filesystems exposed via Pyfilesystem can also be served over the network, or 'mounted' on the native filesystem.
+
+Even if you only need to work with file and directories on the local hard-drive, Pyfilesystem can simplify your code and make it more robust -- with the added advantage that you can change where the files are located by changing a single line of code.
+"""
+
setup(name='fs',
version=VERSION,
description="Filesystem abstraction",
- long_description="Creates a common interface to filesystems",
+ long_description=long_desc,
license = "BSD",
author="Will McGugan",
author_email="will@willmcgugan.com",
url="http://code.google.com/p/pyfilesystem/",
download_url="http://code.google.com/p/pyfilesystem/downloads/list",
platforms = ['any'],
- packages=['fs','fs.expose','fs.expose.fuse','fs.tests','fs.wrapfs',
- 'fs.osfs','fs.contrib','fs.contrib.bigfs','fs.contrib.davfs',
- 'fs.expose.dokan', 'fs.commands'],
+ packages=['fs',
+ 'fs.expose',
+ 'fs.expose.dokan',
+ 'fs.expose.fuse',
+ 'fs.expose.wsgi',
+ 'fs.tests',
+ 'fs.wrapfs',
+ 'fs.osfs',
+ 'fs.contrib',
+ 'fs.contrib.bigfs',
+ 'fs.contrib.davfs',
+ 'fs.contrib.tahoefs',
+ 'fs.commands'],
scripts=['fs/commands/%s.py' % command for command in COMMANDS],
classifiers=classifiers,
)