summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorwillmcgugan <willmcgugan@67cdc799-7952-0410-af00-57a81ceafa0f>2011-12-26 20:52:33 +0000
committerwillmcgugan <willmcgugan@67cdc799-7952-0410-af00-57a81ceafa0f>2011-12-26 20:52:33 +0000
commitb0885a312f4f57c67758850be245db5a34e5c71f (patch)
treeb332b5ce21a5842eea21fa68a627c859d12234d2 /setup.py
parentfafea9afc1fc576062c5c8070ec46ace8183be49 (diff)
downloadpyfilesystem-b0885a312f4f57c67758850be245db5a34e5c71f.tar.gz
First stab at a Python3 port
git-svn-id: http://pyfilesystem.googlecode.com/svn/trunk@724 67cdc799-7952-0410-af00-57a81ceafa0f
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py20
1 files changed, 16 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index bf27a84..fc34be4 100644
--- a/setup.py
+++ b/setup.py
@@ -1,7 +1,13 @@
#!/usr/bin/env python
-from distutils.core import setup
-from fs import __version__ as VERSION
+#from distribute_setup import use_setuptools
+#use_setuptools()
+
+from setuptools import setup
+import sys
+PY3 = sys.version_info >= (3,)
+
+VERSION = "0.4.1"
COMMANDS = ['fscat',
'fscp',
@@ -17,7 +23,7 @@ COMMANDS = ['fscat',
classifiers = [
- 'Development Status :: 3 - Alpha',
+ "Development Status :: 5 - Production/Stable",
'Intended Audience :: Developers',
'License :: OSI Approved :: BSD License',
'Operating System :: OS Independent',
@@ -30,7 +36,12 @@ long_desc = """Pyfilesystem is a module that provides a simplified common interf
Even if you only need to work with file and directories on the local hard-drive, Pyfilesystem can simplify your code and make it more robust -- with the added advantage that you can change where the files are located by changing a single line of code.
"""
-setup(name='fs',
+extra = {}
+if PY3:
+ extra["use_2to3"] = True
+
+setup(install_requires=['distribute'],
+ name='fs',
version=VERSION,
description="Filesystem abstraction",
long_description=long_desc,
@@ -55,5 +66,6 @@ setup(name='fs',
'fs.commands'],
scripts=['fs/commands/%s' % command for command in COMMANDS],
classifiers=classifiers,
+ **extra
)