summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMartin Pitt <martinpitt@gnome.org>2012-11-08 14:54:30 +0100
committerMartin Pitt <martinpitt@gnome.org>2012-11-08 14:54:30 +0100
commitf1a5f1b92d577c542d4258e63e595d4da9acd484 (patch)
treefe61b6dc31f32ca67f777a0ea289e0113fd556a0 /configure.ac
parente46af4aba220cfaf4b84a9be847f3363da556993 (diff)
downloadpygobject-f1a5f1b92d577c542d4258e63e595d4da9acd484.tar.gz
Add support for lcov code coverage
Use gnome-common's new code coverage flags. Default to enabling code coverage in autogen.sh (but not for dist). To use this, run "make check-code-coverage" after building.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 773cc66f..0824be61 100644
--- a/configure.ac
+++ b/configure.ac
@@ -249,6 +249,11 @@ if test "x$GCC" = "xyes"; then
fi
+# enable code coverage support
+GNOME_CODE_COVERAGE
+CFLAGS="$CFLAGS $CODE_COVERAGE_CFLAGS"
+LDFLAGS="$LDFLAGS $CODE_COVERAGE_CFLAGS"
+
AC_CONFIG_FILES(
Makefile
pygobject-3.0.pc
@@ -270,5 +275,6 @@ AC_MSG_RESULT([
libffi support: $have_libffi
cairo support: $enable_cairo
thread support: $enable_thread
+ code coverage support: $enable_code_coverage
])