summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMathieu Duponchelle <mathieu@centricular.com>2018-04-20 23:33:39 +0200
committerMathieu Duponchelle <mathieu@centricular.com>2018-04-20 23:33:39 +0200
commit00779bbaa59bfac4ddf2daa043761a3954a0ded3 (patch)
tree7e40a0388fc543bc1f549e557eea010e4739a62d /meson.build
parented5480e88146b0ce993d6309005762e3507b305d (diff)
downloadpygobject-00779bbaa59bfac4ddf2daa043761a3954a0ded3.tar.gz
meson.build: disable constness warnings
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 8 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index d9ac57bf..e942e395 100644
--- a/meson.build
+++ b/meson.build
@@ -45,6 +45,14 @@ else
pycairo_dep = dependency('pycairo', version : pycairo_version_req, required: false)
endif
+cc = meson.get_compiler('c')
+
+supported_arguments = cc.get_supported_arguments([
+ '-Wno-discarded-qualifiers'])
+
+add_project_arguments(supported_arguments, language: 'c')
+
+
cdata = configuration_data()
cdata.set('PYGOBJECT_MAJOR_VERSION', pygobject_version_major)