summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorChristoph Reiter <reiter.christoph@gmail.com>2019-06-07 16:43:38 +0200
committerChristoph Reiter <reiter.christoph@gmail.com>2019-06-07 16:57:47 +0200
commit179e04b2e7e17ae045c3bb4b43a5ac9c4b460094 (patch)
treeda52920a97c8fc3567929fa0e0d6bda27b21ce25 /meson.build
parent07cb8d7dfc2fe93c3dd0dc4c4ddb88556de048e0 (diff)
downloadpygobject-179e04b2e7e17ae045c3bb4b43a5ac9c4b460094.tar.gz
build: drop some checks for unsupported Python versions
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 1 insertions, 6 deletions
diff --git a/meson.build b/meson.build
index 278fa16f..64e5b809 100644
--- a/meson.build
+++ b/meson.build
@@ -98,6 +98,7 @@ else
'-Wsign-compare',
'-Wstrict-aliasing',
'-Wstrict-prototypes',
+ '-Wswitch-default',
'-Wundef',
'-Wunused-but-set-variable',
'-Wwrite-strings',
@@ -118,12 +119,6 @@ else
'-fvisibility=hidden',
]
- if not ['3.3', '3.4'].contains(python.language_version())
- main_c_args += [
- '-Wswitch-default',
- ]
- endif
-
main_c_args = cc.get_supported_arguments(main_c_args)
endif