summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorChristoph Reiter <reiter.christoph@gmail.com>2020-09-14 09:48:58 +0200
committerChristoph Reiter <reiter.christoph@gmail.com>2020-09-14 09:53:55 +0200
commit6ffc87e51694abd03aed2d42683d65caa74e313d (patch)
treec1c0047317f0051b53005c0dcdf366aed04750ba /meson.build
parent12930c0eba55edec6e91bcde115a90cf959afbe0 (diff)
downloadpygobject-6ffc87e51694abd03aed2d42683d65caa74e313d.tar.gz
Drop Python 3.5 support and bump other dependenciesdrop-py35
Motivated by the EOL of Python 3.5 and the EOL of Ubuntu 16.04 next year this requires Python 3.6 and moves all other dependencies to what is available in Ubuntu 18.04.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build14
1 files changed, 7 insertions, 7 deletions
diff --git a/meson.build b/meson.build
index 087cf2eb..bd07f9f2 100644
--- a/meson.build
+++ b/meson.build
@@ -15,16 +15,16 @@ platform_version = '@0@.0'.format(pygobject_version_major)
pymod = import('python')
python = pymod.find_installation(get_option('python'))
-if python.language_version().version_compare('< 3.5')
- error('Requires Python >= 3.5')
+if python.language_version().version_compare('< 3.6')
+ error('Requires Python >= 3.6')
endif
python_dep = python.dependency()
-glib_version_req = '>= 2.48.0'
-gi_version_req = '>= 1.46.0'
-pycairo_version_req = '>= 1.11.1'
-libffi_version_req = '>= 3.0'
+glib_version_req = '>= 2.56.0'
+gi_version_req = '>= 1.56.0'
+pycairo_version_req = '>= 1.16.0'
+libffi_version_req = '>= 3.2'
gi_dep = dependency('gobject-introspection-1.0', version : gi_version_req,
fallback: ['gobject-introspection', 'girepo_dep'])
@@ -36,7 +36,7 @@ gio_dep = dependency('gio-2.0', version : glib_version_req,
fallback: ['glib', 'libgio_dep'])
gmodule_dep = dependency('gmodule-2.0', version : glib_version_req,
fallback: ['glib', 'libgmodule_dep'])
-ffi_dep = dependency('libffi', version : '>= 3.0',
+ffi_dep = dependency('libffi', version : libffi_version_req,
fallback : ['libffi', 'ffi_dep'])
with_pycairo = get_option('pycairo')