summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorChristoph Reiter <reiter.christoph@gmail.com>2019-10-04 18:53:51 +0200
committerChristoph Reiter <reiter.christoph@gmail.com>2019-10-05 14:01:58 +0000
commit981c059fec195eacdf536a439fb2270a2747abf2 (patch)
tree2f4fd632ecc53fb831c7eb7ac146ba0cdc0df406 /meson.build
parent28962d865f5f4f8e0cf5ba56d1660c06c65e9cff (diff)
downloadpygobject-981c059fec195eacdf536a439fb2270a2747abf2.tar.gz
Drop Python 2 support on Windows
Fixes #363
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 4 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 9cdb1e96..e44f7be0 100644
--- a/meson.build
+++ b/meson.build
@@ -15,6 +15,10 @@ platform_version = '@0@.0'.format(pygobject_version_major)
pymod = import('python')
python = pymod.find_installation(get_option('python'))
+if python.language_version().version_compare('< 3.0') and host_machine.system() == 'windows'
+ error('Python 2 on Windows no longer supported since 3.35. Use Python 3 instead.')
+endif
+
python_dep = python.dependency()
glib_version_req = '>= 2.48.0'