summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorAdam Duskett <Aduskett@gmail.com>2019-03-15 16:09:17 -0400
committerAdam Duskett <Aduskett@gmail.com>2019-03-15 16:09:17 -0400
commitaefb0fb9d1d2bd8dff3679d892ca37b2e28514f2 (patch)
treea7b9fc3dfeae783c1a44a7302aaafa4a7a778607 /meson.build
parent2a3742a0bd5c8d3035bd713d96294426023eef7b (diff)
downloadpygobject-aefb0fb9d1d2bd8dff3679d892ca37b2e28514f2.tar.gz
Add Bool option for tests
Currently, there is no way to prevent tests from building using meson. When cross-compiling, building the tests aren't necessary, and would require gobject-introspection also to be made with tests.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 71dfc4aa..278fa16f 100644
--- a/meson.build
+++ b/meson.build
@@ -174,4 +174,7 @@ configure_file(input : 'PKG-INFO.in',
subdir('gi')
subdir('pygtkcompat')
+with_tests = get_option('tests')
+if with_tests
subdir('tests')
+endif