summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorChristoph Reiter <reiter.christoph@gmail.com>2018-06-24 11:48:39 +0200
committerChristoph Reiter <reiter.christoph@gmail.com>2018-06-24 11:48:39 +0200
commitaf1b2e88211f3d4e0a3c542a5a05f3d0bf86bdac (patch)
tree6c69533e23f5697073d6b2db580a3ad91a71514e /meson.build
parentbeed17372f3dc09aa422ee8dff5ec3bb187b86c3 (diff)
downloadpygobject-af1b2e88211f3d4e0a3c542a5a05f3d0bf86bdac.tar.gz
meson: fix naming/version/path of the .egg-info file
Match what we do with distutils * Use "PyGObject" as package name (it's not case sensitive, but no need to diverge there) * Mark unstable releases as dev releases by adjusting the version number * Install in the right directory (not the gi package)
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build14
1 files changed, 11 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index 70279b85..877cb046 100644
--- a/meson.build
+++ b/meson.build
@@ -142,10 +142,18 @@ configure_file(input : 'pygobject-@0@.pc.in'.format(platform_version),
configuration : pkgconf,
install_dir : pkg_install_dir)
+if pygobject_version_minor.is_odd()
+ py_version = '@0@.dev0'.format(pygobject_version)
+else
+ py_version = pygobject_version
+endif
+
+pkginfo_conf = configuration_data()
+pkginfo_conf.set('VERSION', py_version)
configure_file(input : 'PKG-INFO.in',
- output : 'pygobject-@0@-py@1@.egg-info'.format(pygobject_version, python.language_version()),
- configuration : pkgconf,
- install_dir : python.get_install_dir(subdir : 'gi'))
+ output : 'PyGObject-@0@.egg-info'.format(py_version),
+ configuration : pkginfo_conf,
+ install_dir : python.get_install_dir())
subdir('gi')
subdir('pygtkcompat')