summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorChristoph Reiter <reiter.christoph@gmail.com>2018-05-03 11:34:01 +0200
committerChristoph Reiter <reiter.christoph@gmail.com>2018-05-03 11:34:01 +0200
commitdceb3e339149f0bc7e9f004632a6a24f38ca60ad (patch)
tree85cb2ce45f0562e7b04c59126d641564c61c6d34 /meson.build
parent34805800df9d4468de9dcf0fefc1f45702fcfcb5 (diff)
downloadpygobject-dceb3e339149f0bc7e9f004632a6a24f38ca60ad.tar.gz
build: disable new cast-function-type warnings with gcc8
We have to assign PyCFunctionWithKeywords functions to PyCFunction fields everywhere, so not much we can do. Ideas welcome.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index e2cf42b3..5e553766 100644
--- a/meson.build
+++ b/meson.build
@@ -89,6 +89,7 @@ main_c_args += [
'-Wno-unused-parameter',
'-Wno-discarded-qualifiers',
'-Wno-sign-conversion',
+ '-Wno-cast-function-type',
]
main_c_args += [