summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorChristoph Reiter <reiter.christoph@gmail.com>2023-03-19 10:54:09 +0100
committerChristoph Reiter <reiter.christoph@gmail.com>2023-03-19 11:23:30 +0100
commitf821dbb599c67a2fa0d349b24f23bb6b8855368f (patch)
treef5796919f6d11d3deae6fdfae645781932cfd528 /meson.build
parent960ef271edf9e6968d8c1d46bc8652576cd762c1 (diff)
downloadpygobject-f821dbb599c67a2fa0d349b24f23bb6b8855368f.tar.gz
Drop Python 3.7 support and update CI envs
Python 3.7 will be EOL in 3 months, so before the next release. * Update the Python versions in the CI images * Bump the docker base image from focal to jammy to test against a newer stack. This triggers new deprecation warnings which we need to disable for now. * Bump the old docker based image to from buster to bullseye, moving from Python 3.7 to 3.9.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index a7ffbf8d..efb1b9a6 100644
--- a/meson.build
+++ b/meson.build
@@ -15,8 +15,8 @@ platform_version = '@0@.0'.format(pygobject_version_major)
pymod = import('python')
python = pymod.find_installation(get_option('python'))
-if python.language_version().version_compare('< 3.7')
- error('Requires Python >= 3.7')
+if python.language_version().version_compare('< 3.8')
+ error('Requires Python >= 3.8')
endif
python_dep = python.dependency()