summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorChristoph Reiter <reiter.christoph@gmail.com>2018-08-15 21:51:42 +0200
committerChristoph Reiter <reiter.christoph@gmail.com>2018-08-16 09:16:39 +0200
commitf3d1dc70f1cb0d18738bb293cc7b1bd3a2731c86 (patch)
tree479ae37475771afd7dc4dc3ac81044dc139a5334 /setup.py
parenta7dec0cc0e3b4bb07555581ed9d0f5b6752c3056 (diff)
downloadpygobject-ci-debug-build.tar.gz
ci: build python 2.7 and 3.7 in debug mode. Fixes #243ci-debug-build
It contains more strict checks which might be useful for finding potential bugs. Initialize PyGILState_STATE because gcc can't figure out that state is always defined in the release case when Py_DEBUG is enabled.. Remove -Winline which is triggerd for pygobject_init() with the debug build. Not sure what to do when inlining fails, so just remove the warning for now.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py1
1 files changed, 0 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 3ea5c4ce..38bc2e46 100755
--- a/setup.py
+++ b/setup.py
@@ -893,7 +893,6 @@ def add_ext_compiler_flags(ext, compiler, _cache={}):
"-Wformat-security",
"-Wimplicit-function-declaration",
"-Winit-self",
- "-Winline",
"-Wjump-misses-init",
"-Wlogical-op",
"-Wmissing-declarations",