summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorChristoph Reiter <reiter.christoph@gmail.com>2020-09-14 09:48:58 +0200
committerChristoph Reiter <reiter.christoph@gmail.com>2020-09-14 09:53:55 +0200
commit6ffc87e51694abd03aed2d42683d65caa74e313d (patch)
treec1c0047317f0051b53005c0dcdf366aed04750ba /setup.py
parent12930c0eba55edec6e91bcde115a90cf959afbe0 (diff)
downloadpygobject-6ffc87e51694abd03aed2d42683d65caa74e313d.tar.gz
Drop Python 3.5 support and bump other dependenciesdrop-py35
Motivated by the EOL of Python 3.5 and the EOL of Ubuntu 16.04 next year this requires Python 3.6 and moves all other dependencies to what is available in Ubuntu 18.04.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py8
1 files changed, 4 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index d751dab7..fce5b4af 100755
--- a/setup.py
+++ b/setup.py
@@ -38,10 +38,10 @@ from distutils.spawn import find_executable
PYGOBJECT_VERSION = "3.39.0"
-GLIB_VERSION_REQUIRED = "2.48.0"
-GI_VERSION_REQUIRED = "1.46.0"
-PYCAIRO_VERSION_REQUIRED = "1.11.1"
-LIBFFI_VERSION_REQUIRED = "3.0"
+GLIB_VERSION_REQUIRED = "2.56.0"
+GI_VERSION_REQUIRED = "1.56.0"
+PYCAIRO_VERSION_REQUIRED = "1.16.0"
+LIBFFI_VERSION_REQUIRED = "3.2"
WITH_CAIRO = not bool(os.environ.get("PYGOBJECT_WITHOUT_PYCAIRO"))
"""Set PYGOBJECT_WITHOUT_PYCAIRO if you don't want to build with