summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorChristoph Reiter <reiter.christoph@gmail.com>2018-03-21 15:04:07 +0100
committerChristoph Reiter <reiter.christoph@gmail.com>2018-03-21 15:04:07 +0100
commit84448a33ee741eeeba1121b4d67963dcd95de813 (patch)
treee34463004cfcd93666f956167a592c94771fe434 /setup.py
parent7ac4e21ac31419816a689907b3e9846f74d0c458 (diff)
downloadpygobject-84448a33ee741eeeba1121b4d67963dcd95de813.tar.gz
setup.py: enable -Wjump-misses-init
Just move the error handling code out of the loop as it doesn't depend on the loop state.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 0793a98d..ce257e14 100755
--- a/setup.py
+++ b/setup.py
@@ -738,7 +738,7 @@ def add_ext_warn_flags(ext, compiler, _cache={}):
"-Wimplicit-function-declaration",
"-Winit-self",
"-Winline",
- # "-Wjump-misses-init",
+ "-Wjump-misses-init",
# "-Wlogical-op",
"-Wmissing-declarations",
"-Wmissing-format-attribute",