summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorChristoph Reiter <reiter.christoph@gmail.com>2019-10-04 18:53:51 +0200
committerChristoph Reiter <reiter.christoph@gmail.com>2019-10-05 14:01:58 +0000
commit981c059fec195eacdf536a439fb2270a2747abf2 (patch)
tree2f4fd632ecc53fb831c7eb7ac146ba0cdc0df406 /setup.py
parent28962d865f5f4f8e0cf5ba56d1660c06c65e9cff (diff)
downloadpygobject-981c059fec195eacdf536a439fb2270a2747abf2.tar.gz
Drop Python 2 support on Windows
Fixes #363
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py3
1 files changed, 3 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index cf22ab18..0c817f81 100755
--- a/setup.py
+++ b/setup.py
@@ -1111,6 +1111,9 @@ class build_ext(du_build_ext):
add_ext_compiler_flags(gi_cairo_ext, compiler)
def run(self):
+ if os.name == "nt" and sys.version_info[0] == 2:
+ raise SystemExit("Python 2 on Windows no longer supported since 3.35. Use Python 3 instead.")
+
self._write_config_h()
self._setup_extensions()
du_build_ext.run(self)