summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorChristoph Reiter <reiter.christoph@gmail.com>2018-04-17 15:35:44 +0200
committerChristoph Reiter <reiter.christoph@gmail.com>2018-04-17 15:40:58 +0200
commitc48f60a5d9576736d86d1ef381c3e18ce7bab9ea (patch)
tree9bb39d15146c7349da57a11fd8fb4a632fb4854c /setup.py
parentca20535e993b888f22795a471988ebeb50c492d0 (diff)
downloadpygobject-c48f60a5d9576736d86d1ef381c3e18ce7bab9ea.tar.gz
tests: add our own valgrind suppression file
Contains the two condition errors which happen with Python 3.6.5 at interpreter startup.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py2
1 files changed, 2 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 7da106ba..0326569f 100755
--- a/setup.py
+++ b/setup.py
@@ -651,6 +651,8 @@ def get_suppression_files():
files = []
for prefix in prefixes:
files.extend(get_suppression_files_for_prefix(prefix))
+
+ files.append(os.path.join(get_script_dir(), "tests", "valgrind.supp"))
return sorted(set(files))