summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPaul Pogonyshev <pogonyshev@gmx.net>2009-05-12 23:32:40 +0300
committerPaul Pogonyshev <pogonyshev@gmx.net>2009-05-12 23:32:40 +0300
commit029b2905baec78b370e76e1b2340dc2ee2ddaea1 (patch)
treea34135be1717a7e67d0261b107e8743e67e7ea42 /Makefile.am
parentbec9aad2859e246ee5148494089dcc67c1fd8404 (diff)
downloadpygtk-029b2905baec78b370e76e1b2340dc2ee2ddaea1.tar.gz
Retire hand-written ChangeLog; autocreate from Git history
Basically copied over from GLib source tree.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am33
1 files changed, 33 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 24727273..d2a1635b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -14,6 +14,7 @@ CLEANFILES =
EXTRA_DIST = \
ChangeLog.pre-2-0 \
ChangeLog.pre-2-6 \
+ ChangeLog.pre-2-16 \
config.h.win32 \
MANIFEST.in \
MAPPING \
@@ -29,6 +30,9 @@ EXTRA_DIST = \
m4/jhflags.m4 \
m4/python.m4
+BUILT_EXTRA_DIST = \
+ ChangeLog
+
INCLUDES = \
$(PYTHON_INCLUDES) \
$(PYGOBJECT_CFLAGS) \
@@ -139,6 +143,35 @@ doc-dist:
rm -fr pygtk
+distclean-local:
+ if test $(srcdir) = .; then :; else \
+ rm -f $(BUILT_EXTRA_DIST); \
+ fi
+
+dist-hook: $(BUILT_EXTRA_DIST)
+ files='$(BUILT_EXTRA_DIST)'; \
+ for f in $$files; do \
+ if test -f $$f; then d=.; else d=$(srcdir); fi; \
+ rm -f $(distdir)/$$f && cp $$d/$$f $(distdir) || exit 1; done
+
+
+.PHONY: ChangeLog
+
+ChangeLog:
+ @echo Creating $@
+ @if test -d "$(srcdir)/.git"; then \
+ (GIT_DIR=$(top_srcdir)/.git ./missing --run git log PYGTK_2_15_0^^.. --stat) | fmt --split-only > $@.tmp \
+ && mv -f $@.tmp $@ \
+ || ($(RM) $@.tmp; \
+ echo Failed to generate ChangeLog, your ChangeLog may be outdated >&2; \
+ (test -f $@ || echo git-log is required to generate this file >> $@)); \
+ else \
+ test -f $@ || \
+ (echo A git checkout and git-log is required to generate ChangeLog >&2 && \
+ echo A git checkout and git-log is required to generate this file >> $@); \
+ fi
+
+
all: $(pkgpyexec_LTLIBRARIES:.la=.so)
clean-local:
rm -f $(pkgpyexec_LTLIBRARIES:.la=.so)