summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMatt Wilson <msw@redhat.com>2001-11-29 02:41:43 +0000
committerMatt Wilson <msw@src.gnome.org>2001-11-29 02:41:43 +0000
commit082abe31a6cf2558dbb9d2a12b719abad37f0a2a (patch)
tree1d58f242d4f1038d09da301f19e3b73e05f737b8 /Makefile.am
parentc9af0ca87964169d659fca6b75d7367b8e37803d (diff)
downloadpygtk-082abe31a6cf2558dbb9d2a12b719abad37f0a2a.tar.gz
removed disthook, marked autogenerated .c files as nodist sources.
2001-11-28 Matt Wilson <msw@redhat.com> * gtk/Makefile.am: removed disthook, marked autogenerated .c files as nodist sources. * Makefile.am: likewise. Use a suffix rule instead of a pattern rule for wider make compatibility.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am48
1 files changed, 27 insertions, 21 deletions
diff --git a/Makefile.am b/Makefile.am
index 3163beef..0dd1e6c3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3,31 +3,44 @@ AUTOMAKE_OPTIONS = 1.5
SUBDIRS = codegen gtk
-INCLUDES = $(PYTHON_INCLUDES) $(GLIB_CFLAGS) $(PANGO_CFLAGS) $(ATK_CFLAGS)
+INCLUDES = $(PYTHON_INCLUDES)
pyexec_LTLIBRARIES = gobjectmodule.la pangomodule.la atkmodule.la
gobjectmodule_la_LDFLAGS = -module -avoid-version \
-export-symbols-regex initgobject
-gobjectmodule_la_SOURCES = \
- gobjectmodule.c \
- pygobject.h
+gobjectmodule_la_CFLAGS = $(GLIB_CFLAGS)
+gobjectmodule_la_SOURCES = gobjectmodule.c \
+ pygobject.h
gobjectmodule_la_LIBADD = $(GLIB_LIBS)
-pangomodule_la_LDFLAGS = -module -avoid-version \
- -export-symbols-regex initpango
-pangomodule_la_SOURCES = \
- pangomodule.c \
- pango.c
+# pango module
+
+pangomodule_la_LDFLAGS = -module -avoid-version -export-symbols-regex initpango
+pangomodule_la_CFLAGS = $(PANGO_CFLAGS)
+pangomodule_la_SOURCES = pangomodule.c
+nodist_pangomodule_la_SOURCES = pango.c
pangomodule_la_LIBADD = $(PANGO_LIBS)
+pango.c: pango.defs pango.override
+CLEANFILES = pango.c
+EXTRA_DIST = \
+ pango.defs \
+ pango.override
+
+# atk module
atkmodule_la_LDFLAGS = -module -avoid-version -export-symbols-regex initatk
-atkmodule_la_SOURCES = \
- atkmodule.c \
- atk.c
+atkmodule_la_CFLAGS = $(ATK_CFLAGS)
+atkmodule_la_SOURCES = atkmodule.c
+nodist_atkmodule_la_SOURCES = atk.c
atkmodule_la_LIBADD = $(ATK_LIBS)
+atk.c: pango.defs atk.override
+CLEANFILES += atk.c
+EXTRA_DIST += \
+ atk.defs \
+ atk.override
-%.c: $(srcdir)/%.defs $(srcdir)/%.override
+.defs.c:
(cd $(srcdir)\
&& $(PYTHON) codegen/codegen.py \
--register pango-types.defs \
@@ -43,25 +56,18 @@ pkgincludedir = $(includedir)/pygtk-2.0
noinst_PYTHON = ltihooks.py
-dist-hook:
- -rm -f $(distdir)/pango.c
-
-DISTCLEANFILES = pango.c atk.c
-
defsdir = $(pkgdatadir)/2.0/defs
defs_DATA = pango.defs pango-types.defs
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = pygtk-2.0.pc
-EXTRA_DIST = \
+EXTRA_DIST += \
pygtk.spec \
pygtk.spec.in \
pygtk-2.0.pc.in \
MAPPING \
THREADS \
- atk.defs \
- atk.override \
pango.defs \
pango-types.defs \
pango.override \