summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJohn Finlay <finlay@src.gnome.org>2006-07-06 07:26:54 +0000
committerJohn Finlay <finlay@src.gnome.org>2006-07-06 07:26:54 +0000
commit96ec5d0af9354d536f1d56fafd53dd92d42cbe5c (patch)
tree2a34c55daaaa7354eb1a40d85cdca1937097d4e8 /Makefile.am
parent4ecf6350c933ac2a0f83177dae701a9e5db45fe5 (diff)
downloadpygtk-96ec5d0af9354d536f1d56fafd53dd92d42cbe5c.tar.gz
Add call to _pyatk_register_boxed_types()
* atkmodule.c (initatk): Add call to _pyatk_register_boxed_types() * Makefile.am (ATK_OVERRIDES): Add atkrectangle.override * atkrectangle.override: Add. * atk.override (_wrap_atk_text_get_text_at_offset) (_wrap_atk_text_get_text_before_offset) (_wrap_atk_text_get_character_extents) (_wrap_atk_text_get_run_attributes) (_wrap_atk_text_get_default_attributes) (_wrap_atk_text_get_bounded_ranges, _wrap_atk_text_get_selection) (_wrap_atk_text_get_range_extents): Add, * atk.defs (atk_rectangle_new): Add.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 57ef2f31..1cb20ddc 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -57,9 +57,10 @@ endif
# atk module
ATK_DEFS = atk.defs atk-types.defs
+ATK_OVERRIDES = atk.override atkrectangle.override
CLEANFILES += atk.c
-EXTRA_DIST += $(ATK_DEFS) atk.override
-atk.c: $(ATK_DEFS) atk.override
+EXTRA_DIST += $(ATK_DEFS) $(ATK_OVERRIDES)
+atk.c: $(ATK_DEFS) $(ATK_OVERRIDES)
atk_la_CFLAGS = $(ATK_CFLAGS)
atk_la_LIBADD = $(ATK_LIBS)
atk_la_LDFLAGS = $(common_ldflags) -export-symbols-regex initatk